CKEditor for Drupal 6 Requirements (Open Source Version)

In order to ensure optimal performance, the CKEditor for Drupal module requires the following minimum setup to run correctly.

Server Side

The following server-side setup is recommended for the CKEditor module.

CKEditor for Drupal 6

  • Drupal 6.x
  • PHP 4.4.0 or greater (5.2 recommended)
  • CKEditor 3.4 or greater. You will need to download CKEditor from the official download site: http://ckeditor.com/download. It is recommended to always use the latest CKEditor version available.


Client Side

One of the strongest features of CKEditor is its almost unlimited compatibility. CKEditor is a JavaScript application, so it simply works with all server technologies, just like a simple textarea element. On the client side, it has been developed with all major browsers in mind, and supports Internet Explorer, Mozilla Firefox, Google Chrome, Safari, and Opera. It can even be used in the old and notoriously bug-ridden Internet Explorer 6!

CKEditor browser compatibility is managed according to the Graded Browser Support model proposed by Yahoo!, with some exceptions specific for the requirements of our audience and accessibility needs.

See the CKEditor Compatibility article for a full and up-to-date list of currently supported browsers.

This page was last modified on 30 May 2012, at 09:17.