CKEditor Compatibility

Contents

One of the strongest features of CKEditor is its almost unlimited compatibility. CKEditor is a JavaScript application, so it simply works with all server technologies, just like a simple textarea element. On the client side, it has been developed with all major browsers in mind, and supports Internet Explorer, Mozilla Firefox, Google Chrome, Safari, and Opera. It can even be used in the old and notoriously bug-ridden Internet Explorer 6!

CKEditor browser compatibility is managed according to the Graded Browser Support model proposed by Yahoo!, with some exceptions specific for the requirements of our audience and accessibility needs.

Compatible Browsers

Compatible browsers are divided into two groups — A-grade and X-grade browsers.

A-Graded Browsers

The following is the list of browser versions that will receive A-grade (highest level) support as defined by the CKSource GBS. We aim to provide at least full A-grade support for the following products:
Firefox.png Firefox: all major releases starting from 3.†
Ie.png Internet Explorer: 6.0, 7.0, 8.0, 8.0 Quirks, 9.0
Safari.png Safari 5.†
Opera.png Opera: latest stable
Chrome.png Google Chrome: latest stable

important note
Terms in italics indicate our additions to the YUI GBS. The dagger symbol (†) indicates that the most current non-beta version at that branch level receives support.


All browsers are to be supported for web pages with the Document Type Declaration (doctype) of XHTML 1.0 Transitional except for IE 8 Quirks, which will support unknown doctypes.

X-Graded Browsers

We will follow the YUI GBS approach for X-graded browsers. This group encompasses rare, experimental, or unknown browsers that are assumed to be compatible and modern. QA does not test, and bugs are not opened, against X-graded browsers.

Our X-graded browsers list is different than the YUI one though. It includes the following browsers, except those already included in the A-grade list:

  • Browsers based on the Gecko engine version >= 1.9.0 (Firefox 3.0).
  • Browsers based on the WebKit engine version >= 522 (Safari 3).
  • Opera version >= 9.5.

Accessibility Support

Besides the browser support described above we are also introducing the following table to define the list of browsers and assistive technologies supported by our products.


Windows 7 + JAWS †.† Windows XP High Contrast
Firefox 4.† Firefox.png A-grade A-grade
Internet Explorer 8 Ie.png A-grade

Incompatible Browsers

If you use an older version of one of the browsers listed above, a browser that does not appear in the table, or a browser with JavaScript support turned off, CKEditor's functionality may be limited or the editor might not work at all. In the latter case the editor toolbar will not be visible and you will only be able to enter the HTML code in the textarea element as shown below.

Document source code displayed in a textarea element in a browser that does not support CKEditor


If you want to benefit from all features of a full-fledged version of CKEditor, we recommend installing one of the numerous compatible browsers listed above.

This page was last modified on 23 August 2011, at 16:02.